[unixODBC-support] Unable to get isql working on AIX 7.1

sundarmahadevan82 at gmail.com sundarmahadevan82 at gmail.com
Fri Jan 22 12:37:13 GMT 2016


Hi Nick,
Could you please advice on how to fix this issue? Should I fix PATH variable or is it something else. Appreciate your help.

Sent from my BlackBerry 10 smartphone on the Rogers network.
  Original Message  
From: Nick Gorham
Sent: Thursday, January 21, 2016 6:31 PM
To: unixodbc-support at mailman.unixodbc.org
Reply To: Support for the unixODBC project
Subject: Re: [unixODBC-support] Unable to get isql working on AIX 7.1

On 21/01/16 20:51, Sundar Mahadevan wrote:
> Hi All,
> I am trying to setup oracle database to connect to db2 to pull data 
> using dblink using oracle dg4odbc that comes as part of enterprise 
> edition. My oracle database is on 11gR204 hosted on AIX 7.1 while DB2 
> is on version 10.5 hosted on RHEL 5.11. I am an oracle dba with 
> limited systems administration knowledge looking for assistance in 
> getting my setup working. I installed db2 client which comes with odbc 
> driver and i also installed unix odbc driver manager (both of them 
> installed as OS user dbclient). When i try to execute isql, i am 
> getting the error below. Any help is greatly appreciated.
>
> dbclient at omsa4103:SUPCON(/u13/app/DBCLIENT)> ls -ld 
> /home/oracle/bin/UnixOdbcDriverManager
> drwxrwxr-x 7 oracle dba 256 Jan 21 14:01 
> /home/oracle/bin/UnixOdbcDriverManager

The driver manager has been built with iconv support, but at run time 
cant load the libiconv library.

0509-150 Dependent module /usr/lib/libiconv.a(libiconv.so.2) 
could not be loaded.
0509-152 Member libiconv.so.2 is not found in archive

-- 
Nick
_______________________________________________
unixODBC-support mailing list
unixODBC-support at mailman.unixodbc.org
http://mailman.unixodbc.org/mailman/listinfo/unixodbc-support


More information about the unixODBC-support mailing list