[unixODBC-support] Problem Connecting to WSFC Instance Located in the Cloud

Funny,Solomon Solomon.Funny at fhlbny.com
Thu Apr 21 23:53:49 BST 2016


I am trying to connect to a WSFC instance, which is located in the Cloud, using Freetds.

I am able to connect to a WSFC which is located on premise using Freetds.

I have added the configuration information to the freetds.con and odbc.ini files. I have tried using the server name and the availability group name, but the connection fails with error messages:

[S1000][unixODBC][FreeTDS][SQL Server]Unable to connect to data source
[01000][unixODBC][FreeTDS][SQL Server]Unknown host machine name.

My config files are as follows:

freetds.conf
# On Premise AWS Instance ag-entdbd1\TIGER
[TITAN]
       host = NTS-ENTDBD1
       instance = TITAN
       tds_version = 7.0
       charset = UTF-8

# Cloud AWS Instance ag-entdbd1\TIGER
[TIGER]
       host = NTS-ENTDBD3
       instance = TIGER
       tds_version = 7.0
       charset = UTF-8

-
- on premise WSFC instance connection
-

isql -v TITAN funnys whoami
+---------------------------------------+
| Connected!                                         |
|                                                                  |
| sql-statement                                    |
| help [tablename]                             |
| quit                                                         |
|                                                                  |
+---------------------------------------+
SQL> select count(*) from GLACNT
+------------+
|                     |
+------------+
| 2344          |
+------------+
SQLRowCount returns 1
1 rows fetched


-
- Cloud WSFC instance connection
-

isql -v TIGER funnys whomai
[S1000][unixODBC][FreeTDS][SQL Server]Unable to connect to data source
[01000][unixODBC][FreeTDS][SQL Server]Unknown host machine name.
[ISQL]ERROR: Could not SQLConnect

I have tried using the cluster name instead of a server name, but the connection fails with the same error.

Is it possible, to connect to a WSFC instance located in the cloud, using Freetds?

From: Funny,Solomon
Sent: Thursday, April 21, 2016 10:12 AM
To: 'unixODBC-support at mailman.unixodbc.org'
Subject: freebcp problem with Freetds version 4.2


I am trying to use the freebcp to copy data to a file, but am receiving the following error message:

freebcp prod01.dbo.customer out $HOME/customer.dat -c -Ufunnys -STITAN -Pxxxxxx

                Msg 2410, Level 2
Cannot bcp with TDSVER < 5.0

>From the message, it seems,  freebcp is not supported by Freetds versions earlier than 5.0.

My Freetds version is 4.2

My Unix Admin is telling me he cannot find a Freetds version 5.0 or later.  Is this true or is there a site where I can find a Freetds version 5.0 o later?


Solomon Funny
Database Services
Federal Home Loan Bank of New York
30 Montgomery Street
Jersey City, NJ 07322
(201) 356-1235
solomon.funny at fhlbny.com<mailto:solomon.funny at fhlbny.com>

Confidentiality Notice: The information contained in this e-mail and any attachments (including, but not limited to, any attached e-mails) may be legally privileged and confidential. If you are not an intended recipient, you are hereby notified that any dissemination, distribution or copying of this e-mail is strictly prohibited. If you have received this e-mail in error, please notify the sender and permanently delete the e-mail and any attachments immediately. You should not retain, copy or use this e-mail or any attachment for any purpose, nor disclose all or any part of the contents to any other person.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.unixodbc.org/pipermail/unixodbc-support/attachments/20160421/b2bf7400/attachment-0001.html>


More information about the unixODBC-support mailing list