[unixODBC-support] freebcp problem with Freetds version 4.2

ML d4t4full at gmail.com
Thu Apr 21 15:41:05 BST 2016


*On 2016-04-21 11:12, Funny,Solomon wrote:*
>
> I am trying to use the freebcp to copy data to a file, but am
> receiving the following error message:
>
> freebcp prod01.dbo.customer out $HOME/customer.dat -c -Ufunnys -STITAN
> –Pxxxxxx
>
>                 Msg 2410, Level 2
>
> *Cannot bcp with TDSVER < 5.0*
>
> From the message, it seems,  freebcp is not supported by Freetds
> versions earlier than 5.0.
>
> My Freetds version is 4.2
>
> My Unix Admin is telling me he cannot find a Freetds version 5.0 or
> later.  Is this true or is there a site where I can find a Freetds
> version 5.0 o later?
>
> *Solomon Funny*
>
> *Database Services*
>
> *Federal Home Loan Bank of New York*
>
> *30 Montgomery Street*
>
> *Jersey City, NJ 07322*
>
> *(201) 356-1235*
>
> *solomon.funny at fhlbny.com*
>
Disclaimer: I'm not a developer of unixODBC nor FreeTDS, I'm just a user.

I think "TDSVER" in the error message refers to the protocol used by
FreeTDS to communicate to your server, and not to FreeTDS's version itself.
AFAIK, TDS Version 4.2 is the lowest protocol version FreeTDS supports.
And it has limitations/
You can specify the protocol version in your freetds.conf file; the
usual default is 4.2.
Check these:
  http://www.freetds.org/userguide/envvar.htm#TDSVER
  http://www.freetds.org/userguide/choosingtdsprotocol.htm
  http://www.freetds.org/userguide/freetdsconf.htm

For example, MSSQLServer 2005 will happily work with FreeTDS using TDS
Version 7.2.

HTH,
zxMarce.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.unixodbc.org/pipermail/unixodbc-support/attachments/20160421/e4cb460e/attachment.html>


More information about the unixODBC-support mailing list