[unixODBC-support] Memory leakage induced on changing development platform

SEPS seps at wanadoo.es
Fri Oct 19 14:16:32 BST 2012


Hi Nick,

Tried the Easysoft WP driver (odbc-oraclewp-1.0.3-linux-x86-64-ul64) but it
gave me the following error: [unixODBC][Easysoft][ODBC-ORACLE WP
Driver][ORACLE]General error: OS Version mismatch: Please report this
sequence (AAAF, L6, 3, -1, -1) to Easysoft support at support at easysoft.com

... strange

Then I tried a few more versions of the oracle driver with the same results
as before (constant memory leakage).

Finally, I installed version 2.3.1 of the driver manager from source and the
problem went away (someone should let openSUSE know to update their RPMs).
Now it's quite stable except for 1 additional and very important thing...

I recall that about 18 months ago during initial testing on the client's
64-bit system we had some issues with the C "long" mapping to the ODBC
SQL_C_ULONG on 64-bit platforms. Upon investigating we found some message
thread that said unixODBC would always map a SQL_C_ULONG (SLONG and LONG) to
a 32-bit "C" integer as per the "Microsoft spec" (SQL_C_XBIGINT being used
for 64-bit integers) so we changed a whole bunch of C definitions to "int"
as we only needed 32-bit precision (and wanted to maintain source level
compatability between 32 and 64 bit systems). After installing 2.3.1, it
looks like SQL_C_ULONG is mapping to use 64-bits (32 of which are obviously
occupied by some other data).

Any thoughts on the matter? Any changes made in this regard from versions
2.2 to 2.3 of the driver manager? Would it be something else to investigate
on the Oracle driver side?

Thanks for all your help thusfar and have a nice weekend. Hope to hear from
you soon.

Bill.


-----Original Message-----
From: Nick Gorham [mailto:nick at lurcher.org]
Sent: jueves, 18 de octubre de 2012 17:12
To: SEPS
Subject: Re: [unixODBC-support] Memory leakage induced on changing
development platform


On 18/10/12 15:21, SEPS wrote:
> Hi Nick,
>
> Thanks alot for the speedy response.
>
> Was hoping that there would be a known problem and solution.

Sorry. :-(
>
> I'll check out the oracle issues; OCI does look suspicious but I'd rather
> not commit to Easysoft as my client will have a fit.

Well, I was not suggesting you need to commit to our (Easysoft) driver,
but if you use it as a debug tool and the leak goes away then it points
to the Oracle Oracle driver or the OCI client libs. From the perspective
of a OCI client 10 is a bit long in the tooth now AFAIK.
>
> In the meantime I'd appreciate any other thoughts you might have on the
> subject.

If its a platform you can run valgrind on it might give you more info.

--
Nick



More information about the unixODBC-support mailing list