[unixODBC-support] (unixODBC 2.3.1 OR unixODBC 2.2.14) AND PostgreSQL 9.1 AND Solaris 10 AND psqlodbc-09.01.0100

Nick Gorham nick at lurcher.org
Thu Jun 7 08:11:17 BST 2012


On 07/06/2012 03:47, Hernan Saltiel wrote:
>
>
> On Sun, Jun 3, 2012 at 12:26 PM, Nick Gorham <nick at lurcher.org 
> <mailto:nick at lurcher.org>> wrote:
>
>     On 03/06/2012 16:07, Hernan Saltiel wrote:
>
>
>
>          Thanks a lot for your help!
>         Best regards,
>
>         HeCSa.
>
>     Ok, it may not help  much, but that error means that the driver
>     manager (libodbc.so) has loaded the postgres driver, called
>     SQLAllocHandle( SQL_HANDLE_ENV) or SQLAllocEnv, and then gone on
>     to call SQLAllocHandle( SQL_HANDLE_DBC) or SQLAllocConnect, and
>     that has failed.
>
>     If it was a problem I had here I would look at the postgres driver
>     code starting with SQLAllocHandle, and add some printf debug
>     lines, try and follow the code, and see at what point it returns
>     SQL_ERROR, find why its doing that, and you would have found the
>     cause. Having found the cause, finding the fix is normally simple.
>
>
> Hi Nick,
>
> I tried writing some lines in between the code, and all I have are 
> some messages with no arguments.
> Is there any flag I can use other than "-v" to have more verbosity in 
> the isql output, for example, in order to better understand this error?
> Sorry for this, I'm not a developer, and I'm really trying to get 
> something in some place of the code...
> Thanks, and best regards,
>
> HeCSa.

Hi,

Not as such, have you tried asking the postgresql driver folk, as its in 
the driver that the error is happening.

-- 
Nick
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.unixodbc.org/pipermail/unixodbc-support/attachments/20120607/ae785f69/attachment.html>


More information about the unixODBC-support mailing list