[unixODBC-support] (unixODBC 2.3.1 OR unixODBC 2.2.14) AND PostgreSQL 9.1 AND Solaris 10 AND psqlodbc-09.01.0100

Nick Gorham nick at lurcher.org
Sun Jun 3 16:26:43 BST 2012


On 03/06/2012 16:07, Hernan Saltiel wrote:
>
>
>  Thanks a lot for your help!
> Best regards,
>
> HeCSa.
>
Ok, it may not help  much, but that error means that the driver manager 
(libodbc.so) has loaded the postgres driver, called SQLAllocHandle( 
SQL_HANDLE_ENV) or SQLAllocEnv, and then gone on to call SQLAllocHandle( 
SQL_HANDLE_DBC) or SQLAllocConnect, and that has failed.

If it was a problem I had here I would look at the postgres driver code 
starting with SQLAllocHandle, and add some printf debug lines, try and 
follow the code, and see at what point it returns SQL_ERROR, find why 
its doing that, and you would have found the cause. Having found the 
cause, finding the fix is normally simple.

-- 
Nick


More information about the unixODBC-support mailing list