[unixODBC-support] (unixODBC 2.3.1 OR unixODBC 2.2.14) AND PostgreSQL 9.1 AND Solaris 10 AND psqlodbc-09.01.0100

Nick Gorham nick at lurcher.org
Sat Jun 2 22:01:27 BST 2012


On 02/06/2012 17:57, Hernan Saltiel wrote:
> Hi all!
>
> I'm having several issues trying to make the combination of unixODBC 
> 2.3.1 + psqlodbc-09.01.0100 + Solaris 10 SPARC working.
> At the beggining, I tried compiling unixODBC 2.3.1 with gcc 3.4.6 
> downloaded from Sunfreeware.com. To install Postgresql 9.1 and gcc 
> 3.4.6, I needed also libiconv, libintl, zlib, etc. All of this 
> installs in /usr/local, and Postgresql installs in /usr/local/pgsql.
> unixODBC 2.3.1 compiles perfectly, and also psqlodbc-09.01.0100.
> The problem arises when trying to connect to a database I created for 
> test purposes.
> I created the scweb database with only one table.
> I wrote the /usr/local/etc/odbcinst.ini with this contents:

Is it a 32 or 64 bit build?

When you build the postgres driver, did you tell it to build against 
unixODBC

-- 
Nick


More information about the unixODBC-support mailing list