[unixODBC-support] ./configure is taking forever

Nick Gorham nick at lurcher.org
Sun Feb 5 09:42:16 GMT 2012


On 05/02/2012 03:11, Reza Taheri wrote:
>
> Strace was a good idea. This is what I saw:
>
> -Using strace on odbcinst --q, saw that we were missing the 
> dbcinst.ini file. How is that possible? Well, we are picking up the 
> odbcinst commands from /usr/local/bin instead of /usr/bin. The new 
> command looks for odbcinst.ini in /usr/local/etc, and that file is empty.
>
> oCopy /etc/odbcinst.ini /usr/local/etc
>
> oMake these changes:
> Driver64      = /usr/local/lib/psqlodbcw.so
> Setup64               = /usr/local/lib/libodbcpsqlS.so
>
> oodbcinst now runs OK. But we still get error messages from the SUT 
> process:
> DBConnector: Failed to connect
>
> The driver reported the following diagnostics whilst running 
> SQLDriverConnect
>
> 01000:1:0:[unixODBC][Driver Manager]Can't open lib 
> '/usr/local/lib/psqlodbcw.so' : libodbcinst.so.2: cannot open shared 
> object file: No such  file or directory
>
> The problem is that psqlodbcw.so looks for libodbcinst.so.2, and that 
> file is missing. When I make the unix odbc libraries, I get 
> libodbcinst.so.1
>
> I can fake this out, but I first tried to remake psqlodbc with LDFLAGS 
> set to include /usr/local/lib, but now am running into compilations 
> problems there L.  Will continue tomorrow.
>
>
> Thanks for listening!
>
Building current 2.3.1 or 2.3.2pre from the ftp site will give you the 
so.2 libs.

-- 
Nick
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.unixodbc.org/pipermail/unixodbc-support/attachments/20120205/794b58a2/attachment.html>


More information about the unixODBC-support mailing list