[unixODBC-support] ./configure is taking forever

Nick Gorham nick at lurcher.org
Sat Feb 4 22:23:42 GMT 2012


On 04/02/2012 21:47, Reza Taheri wrote:
>
> Hi Nick,
>
> I am running into some issues that I didn't have with the stock 
> unixODBC-2.2.14-11.el6.x86_64 and 
> postgresql-odbc-08.04.0200-1.el6.x86_64.. I'll be willing to move to 
> 2.3.2pre, but my problems appear to be the type that wouldn't be fixed 
> by such a move.
>
> -Before installing unixODBC from source, I got the source for 
> psqlodbc-08.04.0200. I compiled it and installed it, and switched to 
> it: In odbcinst.ini, changed
> Driver64        = /usr/local/lib/psqlodbcw.so
>
> -It seemed to have worked fine. I could run my test, and using perf 
> record/report, I now get a call graph with function names that I 
> couldn't before (the original psqlodbcw.so library was stripped).
>
> -I tried to do the same thing for unixODBC. I compiled and installed 
> it. But after making the following change, we were still picking up 
> the original drivers in /usr/lib64:
> In odbcinst.ini, changed: Setup64         = /usr/local/lib/libodbcpsqlS.so
>
> -At this point, I moved all the libodbc* modules in /usr/lib64 to a 
> different directory, and copied all the libodbc* files in 
> /usr/local/lib to /usr/lib64
>
> -Now when I try to connect to the PGSQL database, I get:
> DBConnector: Failed to connect
>
> The driver reported the following diagnostics whilst running 
> SQLDriverConnect
>
> IM002:1:0:[unixODBC][Driver Manager]Data source name not found, and no 
> default driver specified
>
> -Following the instructions in 
> http://www.easysoft.com/developer/interfaces/odbc/linux.html, looked 
> for missing libraries. Library /usr/lib64/psqlodbc.so is linked to 
> psqlodbcw.so, which is missing libodbcinst.so.2. So I did:
> ln -s libodbcinst.so.1.0.0 libodbcinst.so.2
>
> -I still get the same error
>
> -Odbcinst gives this error:
> # odbcinst -q -s
> odbcinst: SQLGetPrivateProfileString failed with .
>
> -Obviously, my installation was not totally successful. How can get to 
> a clean, sane state?
>
> -What is the significance of the .1 and .2 suffixes for the libraries?
>

Wen 2.3.1 changed to use 64 bit SQLLEN by default, I changed the minor 
lib number to try and indicate this change has taken place/

Simplest way of seeing whats going on is to use strace to see what goes 
on under the hood.

-- 
Nick
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.unixodbc.org/pipermail/unixodbc-support/attachments/20120204/01ea0b1d/attachment.html>


More information about the unixODBC-support mailing list