[unixODBC-support] ./configure is taking forever

Reza Taheri rtaheri at vmware.com
Sat Feb 4 21:47:46 GMT 2012


Hi Nick,
I am running into some issues that I didn't have with the stock unixODBC-2.2.14-11.el6.x86_64 and postgresql-odbc-08.04.0200-1.el6.x86_64.. I'll be willing to move to 2.3.2pre, but my problems appear to be the type that wouldn't be fixed by such a move.


-          Before installing unixODBC from source, I got the source for psqlodbc-08.04.0200. I compiled it and installed it, and switched to it: In odbcinst.ini, changed
Driver64        = /usr/local/lib/psqlodbcw.so

-          It seemed to have worked fine. I could run my test, and using perf record/report, I now get a call graph with function names that I couldn't before (the original psqlodbcw.so library was stripped).

-          I tried to do the same thing for unixODBC. I compiled and installed it. But after making the following change, we were still picking up the original drivers in /usr/lib64:
In odbcinst.ini, changed: Setup64         = /usr/local/lib/libodbcpsqlS.so

-          At this point, I moved all the libodbc* modules in /usr/lib64 to a different directory, and copied all the libodbc* files in /usr/local/lib to /usr/lib64

-          Now when I try to connect to the PGSQL database, I get:
DBConnector: Failed to connect

The driver reported the following diagnostics whilst running SQLDriverConnect

IM002:1:0:[unixODBC][Driver Manager]Data source name not found, and no default driver specified

-          Following the instructions in http://www.easysoft.com/developer/interfaces/odbc/linux.html, looked for missing libraries. Library /usr/lib64/psqlodbc.so is linked to psqlodbcw.so, which is missing libodbcinst.so.2. So I did:
ln -s libodbcinst.so.1.0.0 libodbcinst.so.2

-          I still get the same error

-          Odbcinst gives this error:
# odbcinst -q -s
odbcinst: SQLGetPrivateProfileString failed with .

-          Obviously, my installation was not totally successful. How can get to a clean, sane state?

-          What is the significance of the .1 and .2 suffixes for the libraries?

My odbcinst.ini is listed below.

Thanks,
Reza

# Example driver definitions

# Driver from the postgresql-odbc package
# Setup from the unixODBC package
[PostgreSQL]
Description     = ODBC for PostgreSQL
Driver          = /usr/lib/psqlodbc.so
Setup           = /usr/lib/libodbcpsqlS.so
Driver64        = /usr/lib64/psqlodbc.so
Setup64         = /usr/lib64/libodbcpsqlS.so
FileUsage       = 1


# Driver from the mysql-connector-odbc package
# Setup from the unixODBC package
[MySQL]
Description     = ODBC for MySQL
Driver          = /usr/lib/libmyodbc5.so
Setup           = /usr/lib/libodbcmyS.so
Driver64        = /usr/lib64/libmyodbc5.so
Setup64         = /usr/lib64/libodbcmyS.so
FileUsage       = 1

From: unixodbc-support-bounces at mailman.unixodbc.org [mailto:unixodbc-support-bounces at mailman.unixodbc.org] On Behalf Of Nick Gorham
Sent: Saturday, February 04, 2012 5:33 AM
To: Support for the unixODBC project
Subject: Re: [unixODBC-support] ./configure is taking forever

On 04/02/2012 12:54, Reza Taheri wrote:
Hi Nick,
Thanks for the reply. It is indeed repeating the same loop. I was more careful this time, and captured strace with a -f, which showed it spawns a child process that looks for "//lib/libQt*" and fails. I looked for qt rpms on the RHEL 6.1 DVD. There is a bunch, but they all require a number of missing dependent libraries. Not sure where to get libQt*, etc.

No, I don't need the gui. I set -enable-gui=no, and it finished cleanly and quickly. Thanks for the tip! (I am installing this particular version because I ran into a performance problem with the rpm, and want to track it down using its source.)

Ok, cool, if you find anything that you think needs fixing in the current tree (2.3.2pre) just let me know.

--
Nick
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.unixodbc.org/pipermail/unixodbc-support/attachments/20120204/336ab421/attachment-0001.html>


More information about the unixODBC-support mailing list