[unixODBC-support] ./configure is taking forever

Reza Taheri rtaheri at vmware.com
Sat Feb 4 12:54:55 GMT 2012


Hi Nick,
Thanks for the reply. It is indeed repeating the same loop. I was more careful this time, and captured strace with a -f, which showed it spawns a child process that looks for "//lib/libQt*" and fails. I looked for qt rpms on the RHEL 6.1 DVD. There is a bunch, but they all require a number of missing dependent libraries. Not sure where to get libQt*, etc.

No, I don't need the gui. I set -enable-gui=no, and it finished cleanly and quickly. Thanks for the tip! (I am installing this particular version because I ran into a performance problem with the rpm, and want to track it down using its source.)

Thx,
Reza

From: unixodbc-support-bounces at mailman.unixodbc.org [mailto:unixodbc-support-bounces at mailman.unixodbc.org] On Behalf Of Nick Gorham
Sent: Saturday, February 04, 2012 1:00 AM
To: Support for the unixODBC project
Subject: Re: [unixODBC-support] ./configure is taking forever

On 04/02/2012 02:33, Reza Taheri wrote:
Hi,
This is my first time compiling the unixODBC package. I got the unixODBC-2.2.14-11.el6.src.rpm file, and installed it on an RHEL 6.1 (2.6.32-131.0.15.el6.x86_64) system. I didn't change anything in configure.in. I ran ./configure, and it has been running for over an hour on a pretty beefy server with plenty of CPU, memory, and disks. The last lines in configure.log are:

configure:26429: result: yes
configure:26524: checking for Qt
configure:26621: Checking dir /usr/include
configure:26646: checking for Qt headers
configure:26680: result: /usr/include
configure:26683: checking for Qt4 headers
configure:26687: result: yes
configure:26695: checking include layout
configure:26698: result: v4 layout
configure:26718: Found Qt version 040602
configure:26724: checking for Qt libraries

There are no files newer than configure.log in the source tree. I have attached an strace output of the process below. Should I let this just go on, or is there something wrong?


Not much help, but I would guess its in a loop somewhere looking for Qt, I don;t know if a longer strace shows any repeated activity?

I guess the simple question is do you need the gui part, and why not build from newer source?

--
Nick
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.unixodbc.org/pipermail/unixodbc-support/attachments/20120204/4fb05454/attachment.html>


More information about the unixODBC-support mailing list