[unixODBC-support] odbcinst failing

Nick Gorham nick at lurcher.org
Thu Jul 28 14:09:04 BST 2011


On 28/07/11 13:47, Davies Matt J A (LCSS) wrote:
> libodbcinst.so.1 =>  /usr/lib32/libodbcinst.so.1 (0xf775a000)
I think thats the problem. Your distribution already has a 
libodbcinst.so, so you are using a 2.3.0 binary with a 2.2.x library.

In 2.3.1 I have changed the version number so it should avoid that 
problem. I should have done it when 2.3 was released.

  ldd /usr/local/bin/odbcinst
         linux-gate.so.1 =>  (0x00672000)
         libodbcinst.so.2 => /usr/local/lib/libodbcinst.so.2 (0x00184000)
         libltdl.so.7 => /usr/lib/libltdl.so.7 (0x00b40000)
         libdl.so.2 => /lib/tls/i686/cmov/libdl.so.2 (0x00715000)
         libpthread.so.0 => /lib/tls/i686/cmov/libpthread.so.0 (0x00da5000)
         libc.so.6 => /lib/tls/i686/cmov/libc.so.6 (0x00194000)
         /lib/ld-linux.so.2 (0x005de000)

-- 
Nick



More information about the unixODBC-support mailing list