[unixODBC-support] Force 32 bit install on 64 bit Linux

Roger Heim reheim at fedex.com
Mon Jan 24 22:44:18 GMT 2011


I'm already including "-disable-gui" in the config line.

Not more than 15 minutes after I sent this out - one of the "sys admin
types" suggested that I should have used "CFLAGS=-m32" instead of just
"CFLAGS=m32".

I tried it with that - and it worked correctly!

I think we're good to go now.

 

As to the version - the co-worker who did the initial development spent
almost 2 months going back and forth trying different things and finally
learned that the newer version that was on our Linux boxes was causing
the problem. When she moved back to 2.2.12 it worked fine.

 

The application we're trying to enable hasn't been updated in several
years - so that's probably why it has problems with the newer version.

Roger Heim
Technical Advisor
FedEx Corporate Services



From: unixodbc-support-bounces at mailman.unixodbc.org
[mailto:unixodbc-support-bounces at mailman.unixodbc.org] On Behalf Of Nick
Gorham
Sent: Monday, January 24, 2011 4:20 PM
To: Support for the unixODBC project
Subject: Re: [unixODBC-support] Force 32 bit install on 64 bit Linux

 

On 24/01/2011 20:45, Roger Heim wrote: 

Setting the "CFLAGS" value helped a lot - but now we're getting an error
during the "config" process about the C Compiler.

 

Here's what I think were the relevant lines from the config.log:


Add 

--enable-gui=no 

to the configure line.

BTW, 2.2.12 is very old now, current release is 2.3.0

-- 
Nick

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.unixodbc.org/pipermail/unixodbc-support/attachments/20110124/7ba1cea7/attachment-0001.html>


More information about the unixODBC-support mailing list