[unixODBC-support] Postgres ODBC driver with unixODBC 2.3

Kilburn Abrahams kilburna at gmail.com
Mon Sep 20 12:28:30 BST 2010


  psqlodbc-08.04.0200 is the latest version on the postgres website. Ok, 
I will ask if there is a newer or the correct version of the ODBC driver 
for 64bit.

On 20/09/2010 6:53 PM, Nick Gorham wrote:
>  On 20/09/2010 08:11, Kilburn Abrahams wrote:
>>  Hi list
>>
>> I somehow cannot compile postgres ODBC driver 08.04.200 with unixODBC 
>> 2.3 on 64 bit system. The configure seems fine but always errors out 
>> in the function 'SQLProcedures'.
>>
>> CHOST="x86_64-pc-linux-gnu"
>> CFLAGS="-march=native -O2 -pipe"
>> CXXFLAGS="${CFLAGS}"
>>
>> ./configure --prefix=/usr --datadir=/usr/share --sysconfdir=/etc 
>> --localstatedir=/var/lib --libdir=/usr/lib64 
>> --with-libpq=/usr/include/postgresql --with-gnu-ld --disable-pthreads 
>> --enable-unicode --with-unixodbc
> I will take a look at it, but that postgresql driver is not 
> recommended for use now. You are advised to use the current one from 
> the folks maintaining the postgresql project.
>


More information about the unixODBC-support mailing list