[unixODBC-support] Postgres ODBC driver with unixODBC 2.3

Nick Gorham nick at lurcher.org
Mon Sep 20 09:53:00 BST 2010


  On 20/09/2010 08:11, Kilburn Abrahams wrote:
>  Hi list
>
> I somehow cannot compile postgres ODBC driver 08.04.200 with unixODBC 
> 2.3 on 64 bit system. The configure seems fine but always errors out 
> in the function 'SQLProcedures'.
>
> CHOST="x86_64-pc-linux-gnu"
> CFLAGS="-march=native -O2 -pipe"
> CXXFLAGS="${CFLAGS}"
>
> ./configure --prefix=/usr --datadir=/usr/share --sysconfdir=/etc 
> --localstatedir=/var/lib --libdir=/usr/lib64 
> --with-libpq=/usr/include/postgresql --with-gnu-ld --disable-pthreads 
> --enable-unicode --with-unixodbc
I will take a look at it, but that postgresql driver is not recommended 
for use now. You are advised to use the current one from the folks 
maintaining the postgresql project.

-- 
Nick


More information about the unixODBC-support mailing list