[unixODBC-support] Huge problems connecting to a DB2 database.

Nicklas Börjesson Nicklas.Borjesson at ws.se
Sun Sep 19 12:55:48 BST 2010

>> Hi,
>> The SQL10007N error message also seems related to the DB2INSTANCE variable, so I can't make db2 work either.
>> I don't have any idea of where to go from here.
>> Also, most examples on how to solve the issue refers to connecting to local instances, not remote ones like I am, complicating further.
>When I did this, you had to do something called "catalog the database".
>This may be a place to start
Hi, and thanks for you help.

The problem is that the server and the client are 9.7, and that the link describes the procedure for 8.0.
I tried to follow it anyway, though but to not avail.
The b2profile script seems to think that all files should be located under the SQLLib folder, which doesn't exist in any of my client installations. The article even says that the b2profile script itself should be located there. Instead it is located under the cfg folder. 
It even looks the same in my 8.1 installation, no idea how that script is supposed to work, really.
Of course, I could edit the script to use that folder instead, but that would risk my entire installation.

Anyway, I ran that script, got no output, ran the db2 utility (as stated in the guide) and got the same error.


More information about the unixODBC-support mailing list