[unixODBC-support] trouble with mysql driver on mono

James Smith james.smith at aleph-one.com
Sun May 9 11:24:06 BST 2010


Nick,

firstly, many thanks for the reply and apologies for getting back to you so
late. I'm away during the weekends so this issue is for the weekend.

So, I tried your suggestion of adding tracing. Here is my /etc/odbcinst.ini
file now:

[MySQL]
Description	= MySQL ODBC 3.51 Driver
Driver		= /usr/lib/odbc/libmyodbc.so
Setup		= /usr/lib/odbc/libodbcmyS.so
CPTimeout	=
CPReuse	=

[ODBC]
Trace=Yes
TraceFile = /tmp/sql.log

After a reboot I see no /tmp/sql.log file, however. I've checked the
permissions on the /tmp directory and they're 777 so there shouldn't be any
problems there. The only other thing I can think of is that the
/etc/odbcinst.ini file isn't being read at all, which from my basic
understanding of UnixODBC seems unlikely. Any ideas from here?

One thing to note is that on the previous installation on a different VPS
provider, both the odbc.ini and odbcinst.ini files were empty, and yet ODBC
still worked. I initially added the above MySQL entry manually only as a
last resort. So how did UnixODBC register the MySQL driver on the previous
installation, and is this at all related to my current situation?

Many thanks again.

Kind regards,

James




More information about the unixODBC-support mailing list