[unixODBC-support] unixODBC not working with psqlodbc 08.04.0200 on Linux x64

Nick Gorham nick at lurcher.org
Sun Feb 14 19:13:13 GMT 2010


Luke Coldiron wrote:
> I am trying to get unixODBC version 2.2.12 to work with psqlodbc 
> version 08.04.0200.  Has anyone been able to get this to work?  I am 
> running on Linux x64.  I could not get unixODBC version 2.2.14 or 
> 2.2.15pre to compile but I was able to get 2.2.12 to compile.  I can 
> connect to my Postgres 8.4.2 database using the Postgres 7.1 driver 
> that comes with unixODBC but I am not able to with the psqlodbc 
> 08.04.0100 or 08.04.0200 drivers.  These are the only others that I 
> tried.  I tried turning on sql logging but it does not seem to get to 
> the point where it actually logs anything.  So I am wondering if there 
> is anything that I have overlooked in theory that would prevent the 
> psqlodbc driver from working with unixODBC.  Any help would be much 
> appreciated.
> Luke
> _______________________________________________
> unixODBC-support mailing list
> unixODBC-support at mailman.unixodbc.org
> http://mailman.unixodbc.org/mailman/listinfo/unixodbc-support
Hi,

Not that I can think of, did you build the postgres drivers with the 
--with-unixODBC flag so it used the ini libs?

The only area of problem is/was with the size of unicode characters, but 
I think thats resolved now.

What problem was there getting2.2.15pre to compile?

Does the driver you are trying to use need the postgres client libs?

Do you get any error back when you use

isql -v dsn

The -v enables displaying errors.

-- 
Nick


More information about the unixODBC-support mailing list