[unixODBC-support] UnixODBC -> FreeTDS -> MSSQL login failure ...

Donovan Allen allend at puresimple.org
Tue Apr 20 00:13:58 BST 2010


I have poured over logs from both freetds and unixodbc, and while obviously more verbose, shed no more light on the problem.  However, I think I may have resolved it.

I did two things, so sadly I am not sure yet which may have fixed it:

1> Updated the glibc common rpm on my CentOS (which contains iconv)
2> Re-compiled freetds 0.82 with the following configure options:
./configure --prefix=/usr --sysconfdir=/etc --enable-msdblib --enable-sybase-compat --enable-extra-checks --with-tdsver=8.0

isql is working so far with:
SELECT * FROM INFORMATION_SCHEMA.TABLES WHERE TABLE_TYPE = 'BASE TABLE'

osql seems to be broken now (maybe I best recompile unixODBC and then FreeTDS again after glibc update)

> osql: error: no potential directory strings in "/usr/bin/isql"
> isql strings are:
> + /lib/ld-linux.so.2
> ? + /lib/ld-linux.so.2

However, so far, DBD::ODBC via perl seems to be working.


________________________________________
From: unixodbc-support-bounces at mailman.unixodbc.org [unixodbc-support-bounces at mailman.unixodbc.org] On Behalf Of Nick Gorham [nick at lurcher.org]
Sent: Monday, April 19, 2010 3:04 PM
To: Support for the unixODBC project
Subject: Re: [unixODBC-support] UnixODBC -> FreeTDS -> MSSQL login failure ...

Donovan Allen wrote:
> Thanks for the suggestion, but I long ago tried that.  I provided the osql dump because it is more explanatory about how I am correctly loading config files etc ... to prempt responses to that effect.
>
> Fundamentally, it is spitting out the same message from my application, a perl program using DBD::ODBC.
>

I would look at driver logging to see where the difference is.

--
Nick
_______________________________________________
unixODBC-support mailing list
unixODBC-support at mailman.unixodbc.org
http://mailman.unixodbc.org/mailman/listinfo/unixodbc-support


More information about the unixODBC-support mailing list