[unixODBC-support] domain login fails in isql but works with tsql

Eric Robinson (erirobin) erirobin at cisco.com
Fri Apr 16 20:49:59 BST 2010


I think I may have found my issue, it appears that the password was
getting cut off at 6 characters, the full password is 8 characters and
the 7th position is a + sign. 

Looks like it caused the password to get truncated and may have caused
all my pain.

[ODBC][10702][__handles.c][444]
                Exit:[SQL_SUCCESS]
                        Environment = 0x508320
[ODBC][10702][SQLAllocHandle.c][345]
                Entry:
                        Handle Type = 2
                        Input Handle = 0x508320
[ODBC][10702][SQLAllocHandle.c][463]
                Exit:[SQL_SUCCESS]
                        Output Handle = 0x508980
[ODBC][10702][SQLConnect.c][3549]
                Entry:            
                        Connection = 0x508980            
                        Server Name = [MSSQLSRV][length = 8 (SQL_NTS)]

                        User Name = [XXXXX\xxxxxxxx.xxx][length = 18
(SQL_NTS)]            
                        Authentication = [******][length = 6 (SQL_NTS)]
                UNICODE Using encoding ASCII 'ISO8859-1' and UNICODE
'UCS-2LE'

                DIAG [42000] [FreeTDS][SQL Server]Login failed for user
''. The user is not associated with a trusted SQL Server connection.

                DIAG [S1000] [FreeTDS][SQL Server]Unable to connect to
data source

[ODBC][10702][SQLConnect.c][3917]
                Exit:[SQL_ERROR]
[ODBC][10702][SQLFreeHandle.c][268]
                Entry:
                        Handle Type = 2
                        Input Handle = 0x508980
[ODBC][10702][SQLFreeHandle.c][317]
                Exit:[SQL_SUCCESS]
[ODBC][10702][SQLFreeHandle.c][203]
                Entry:
                        Handle Type = 1
                        Input Handle = 0x508320

-----Original Message-----
From: unixodbc-support-bounces at mailman.unixodbc.org
[mailto:unixodbc-support-bounces at mailman.unixodbc.org] On Behalf Of Nick
Gorham
Sent: Thursday, April 15, 2010 6:20 PM
To: Support for the unixODBC project
Subject: Re: [unixODBC-support] domain login fails in isql but works
with tsql

Eric Robinson (erirobin) wrote:
> I am assuming it is some bug as I could not find any setting or format
> for the -U DOMIAN/UserId that would work with isql.
>
> I have the trace files and dump files that appear to show it parsing
the
> domain and userid ok, but it would not connect.
>
> I used the same exact setup with a Sql Server authenticated userid and
> it worked fine, then I pointed dg4odbc to the same setup and it worked
> for both Sql Server authenticated user and the network user.
>
> I could very well have an outdated version of isql. 
>
> I would be glad to send you any addition details (trace files/sql
server
> logs) I can if you are interested.
>   
Yep, a ODBC driver manager log would be interesting. Its not a big 
issue, but I am wondering what the problem was thats fixed.

All I can think of is older isql used to pass a empty string for user 
name and password if it wasn't passed on the command line.That may be 
the problem here.

-- 
Nick
_______________________________________________
unixODBC-support mailing list
unixODBC-support at mailman.unixodbc.org
http://mailman.unixodbc.org/mailman/listinfo/unixodbc-support


More information about the unixODBC-support mailing list