[unixODBC-support] domain login fails in isql but works with tsql

Nick Gorham nick at lurcher.org
Thu Apr 15 23:20:07 BST 2010


Eric Robinson (erirobin) wrote:
> I am assuming it is some bug as I could not find any setting or format
> for the -U DOMIAN/UserId that would work with isql.
>
> I have the trace files and dump files that appear to show it parsing the
> domain and userid ok, but it would not connect.
>
> I used the same exact setup with a Sql Server authenticated userid and
> it worked fine, then I pointed dg4odbc to the same setup and it worked
> for both Sql Server authenticated user and the network user.
>
> I could very well have an outdated version of isql. 
>
> I would be glad to send you any addition details (trace files/sql server
> logs) I can if you are interested.
>   
Yep, a ODBC driver manager log would be interesting. Its not a big 
issue, but I am wondering what the problem was thats fixed.

All I can think of is older isql used to pass a empty string for user 
name and password if it wasn't passed on the command line.That may be 
the problem here.

-- 
Nick


More information about the unixODBC-support mailing list