[unixODBC-support] domain login fails in isql but works with tsql

Eric Robinson (erirobin) erirobin at cisco.com
Thu Apr 15 22:37:22 BST 2010


I am assuming it is some bug as I could not find any setting or format
for the -U DOMIAN/UserId that would work with isql.

I have the trace files and dump files that appear to show it parsing the
domain and userid ok, but it would not connect.

I used the same exact setup with a Sql Server authenticated userid and
it worked fine, then I pointed dg4odbc to the same setup and it worked
for both Sql Server authenticated user and the network user.

I could very well have an outdated version of isql. 

I would be glad to send you any addition details (trace files/sql server
logs) I can if you are interested.

If you have any ideas on what to check/change to fix the issue I am
interested as I would like to have a way to test each component along
the chain, in case something goes south in the future.

Eric

-----Original Message-----
From: unixodbc-support-bounces at mailman.unixodbc.org
[mailto:unixodbc-support-bounces at mailman.unixodbc.org] On Behalf Of Nick
Gorham
Sent: Thursday, April 15, 2010 5:26 PM
To: Support for the unixODBC project
Subject: Re: [unixODBC-support] domain login fails in isql but works
with tsql

Eric Robinson (erirobin) wrote:
> So UNIXodbc and FreeTDS both are working fine now :)
>
> My end goal was to use Oracle DG4ODBC -> UNIXodbc -> FreeTDS to access
> MSSQL from Oracle using a domain\userid and that is working fine.
>
> Apparently there is a bug in the isql on the box I am on and I wrongly
> assumed it was provided by UNIXodbc (my bad). It is not associated
with
> any RPM so I have no clue what installed it, probably provided by
> RedHat.
>
> Thanks again for your responses,
>
> Eric
>   
It would have come from unixODBC originally, do you know what the bug
was?

-- 
Nick
_______________________________________________
unixODBC-support mailing list
unixODBC-support at mailman.unixodbc.org
http://mailman.unixodbc.org/mailman/listinfo/unixodbc-support


More information about the unixODBC-support mailing list