[unixODBC-support] RE : RE : RE : ODBCConfig not loading setuplibrary

Ludo Brands ludo.brands at free.fr
Wed Apr 7 20:27:22 BST 2010


strace shows a normal load of the library file. 
Got gdb fired up and finally found the problem: before starting the gui I
test if gtk2 is installed by checking on libgtk-x11-2.0.so. Fedora (haven't
tested Suse yet) doesn't have this short symbolic link. It only has
libgtk-x11-2.0.so.0. When gtk2 is not detected my setup library falls back
to adding a DSN from the attributes passed in the call to ConfigDSN. Since
there is no user interface the setup library needs at a minimum a DSN name
which obviously ODBCConfig didn't supply when adding a new DSN. ConfigDSN
returns false with a SQLPostInstallerError but ODBCConfig doesn't recognise
this... Fixing the link solves the problem. Why the debug write to console
isn't working is still a mystery. 

So, nothing wrong with odbcinst and unixodbc. Sorry for the false alarm.
Debugging libraries should be easier. Thanks a lot for the help.

Ludo


-----Message d'origine-----
De : unixodbc-support-bounces at mailman.unixodbc.org
[mailto:unixodbc-support-bounces at mailman.unixodbc.org] De la part de Nick
Gorham
Envoyé : mercredi 7 avril 2010 17:36
À : Support for the unixODBC project
Objet : Re: [unixODBC-support] RE : RE : ODBCConfig not loading setuplibrary


Ludo Brands wrote:
> dltest reports "SUCCESS: Found ConfigDSN"
>   
Not sure what to suggest, maybe use strace to see whats going on under 
the hood.

-- 
Nick
_______________________________________________
unixODBC-support mailing list unixODBC-support at mailman.unixodbc.org
http://mailman.unixodbc.org/mailman/listinfo/unixodbc-support



More information about the unixODBC-support mailing list