[unixODBC-support] [IM002][unixODBC][Driver Manager]Data sourcename not found, and no default driver specified

Ged Melia meliag at wwwebi.net
Tue Oct 13 18:39:39 BST 2009


Hi Nick

Thanks for your response (again!)

> I normally suggest using strace to try and find if the app tries to load 
> the lib, if it does its found the entry in the ini file, and its failing 
> when loading the lib. If not then strace will show what ini file was 
> opened, which may not be the one that is expected.

strace is one of those things that I tried prior to making my initial post. 
The only odbc.ini file I have on the filesystem is in /etc and this is the 
one which was opened and examined.
The permissions of the file must be accurate as the comments I placed in the 
file were also visible in the strace.

> There have been many people over the years who have seen that error 
> message, and AFAIK most have found resolutions.
I suspect you are correct but, of all of the resolutions I noted on the 
numerous google searches, none of them resolved my issue.


I have to wonder if the 64bit installation has anything to do with it?
Your first response even asked a question regarding lib64 which made me 
believe you were onto something (and that my initial thoughts may have some 
bearing).

If I get the time, I'll rebuild this on a 32bit architecture.

GM



-- 
This message has been scanned for viruses and dangerous content by DFK Systems Limited, and is believed to be clean.
To report this message as spam, please click on this link - https://secure.dfk-systems.com/quarantine/spam.php?srv=01&id=n9DHdeHQ018834



More information about the unixODBC-support mailing list