[unixODBC-support] Cannot find host with InterSystems Cache 5.0.20 driver

Nick Gorham nick at lurcher.org
Sun Oct 4 16:59:32 BST 2009


Casey Allen Shobe wrote:
> Well, setting $ODBCINI fixed it!  I'd actually tried that before, but 
> I was setting it to something the scripts that accompanied the driver 
> software generated for iODBC, not unixODBC's configuration file in 
> /etc.  Pointing it at /etc/odbc.ini did the trick!  That was simple...
>
> Would you mind letting me know how I would go about using strace in 
> this situation though, for my own reference?  I'd like to be able to 
> troubleshoot things like this on my own if possible.
>
> Sadly the authors don't seem to respond to E-mail (have been waiting a 
> week), and probably they would want me to use a current version (which 
> is protocol-level incompatible with the ancient version of the 
> database our software requires).
>
> Thanks so much!

I normally do:

strace isql dsn pwd 2 >sl

the use grep or vi on the sl file and look for open() system calls. This 
will show the files its trying to open. You will see when the driver lib 
is loaded, and that will be followed by something trying to open a 
odbc.ini somewhere.

-- 
Nick


More information about the unixODBC-support mailing list