[unixODBC-support] Cannot find host with InterSystems Cache 5.0.20 driver

Casey Allen Shobe casey at shobe.info
Sun Oct 4 14:50:48 BST 2009


Well, setting $ODBCINI fixed it!  I'd actually tried that before, but I was
setting it to something the scripts that accompanied the driver software
generated for iODBC, not unixODBC's configuration file in /etc.  Pointing it
at /etc/odbc.ini did the trick!  That was simple...
Would you mind letting me know how I would go about using strace in this
situation though, for my own reference?  I'd like to be able to troubleshoot
things like this on my own if possible.

Sadly the authors don't seem to respond to E-mail (have been waiting a
week), and probably they would want me to use a current version (which is
protocol-level incompatible with the ancient version of the database our
software requires).

Thanks so much!
-- 
Casey Allen Shobe

On Sun, Oct 4, 2009 at 5:05 AM, Nick Gorham <nick at lurcher.org> wrote:

> Casey Allen Shobe wrote:
>
>> Hi,
>>
>> I'm attempting to use an InterSystems Cache 5.0.20 x86_64 driver with
>> unixODBC.
>>
>> I believe I have the INI files configured correctly - I've tried two
>> different driver configs (outlined below) with the exact same results.
>>
>> I've verified the unixodbc installation is working by testing a PostgreSQL
>> installation, but when I try to connect to a Cache (4.1.3) server, using the
>> exact same parameters as on a Windows VM running on the same host (which
>> works), I get a "Host not found" error.
>>
>> Here is my odbcinst.ini:
>>
> I would check the driver is using the same odbc.ini, I don't know if that
> driver uses unixOIDBC to read the ini or does its itself. Try setting
> ODBCINI env variable to the location of the odbc.ini file you are using.
> Also if you have it, check with strace what ini files are being opened after
> the driver lib has been loaded.
>
> Failing that, I would check with the driver writers, at that point unixODBC
> has loaded the driver and its up to the driver to get the values from the
> ini file.
>
> --
> Nick
> _______________________________________________
> unixODBC-support mailing list
> unixODBC-support at mailman.unixodbc.org
> http://mailman.unixodbc.org/mailman/listinfo/unixodbc-support
>



-- 
Casey Allen Shobe
casey at shobe.info
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.unixodbc.org/pipermail/unixodbc-support/attachments/20091004/2d6a1a28/attachment.html>


More information about the unixODBC-support mailing list