[unixODBC-support] ok from commandline but not from codeblocks

Ken Resander kresander at yahoo.com
Mon May 25 15:19:00 BST 2009


Sorry, I was unclear.

This is a new problem, I think.

The previous problem caused 'can't find Oracle driver lib so file' error when running the program (developed on codeblocks) from the commandline and when running it from the codeblocks IDE. I used strace and figured out the ORACLE_HOME was wrong. When I changed ORACLE_HOME the same program as before connected to Oracle OK from the command line, but gave 'can't find Oracle driver lib so file' error when run from within codeblocks. I expected it to work from codeblocks too. 

My theory is that codeblocks changes/disturbs the env environment or does not expose the same environment as when the program is run from the commandline, but I cannot think of what to do to demonstrate this. I was hoping you might have seen this kind of problem before and point me in the right direction.

Ken



You wrote

> I am unsure from your email if you have solved the problem and are listing a new
> problem, or if its the problem you have solved.

> -- Nick 




      New Email addresses available on Yahoo!
Get the Email name you've always wanted on the new @ymail and @rocketmail. 
Hurry before someone else does!
http://mail.promotions.yahoo.com/newdomains/aa/
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.unixodbc.org/pipermail/unixodbc-support/attachments/20090525/863102f5/attachment.html>


More information about the unixODBC-support mailing list