[unixODBC-support] Conflicting types betweenpostgres andunixodbc

Raul Orduna rorduna at tracasa.es
Fri Mar 27 11:25:57 GMT 2009


Thank you for details. In this case make return a lot of warning due to differences in signedness. Finally odbcapi.lo returns an error (without verbose).

It seems impossible to build the driver postgres :(

>
>Summarizing:
>I have a dump of postgress data I must migrate to Oracle (a really complex project...really). The process must be iterative and repeatedly.
>
>For this objective I want to access from oracle to postgresql via heterogeneous services and odbc. This integration, theoretically simple, cause problems in both sides.
>
>The oracle part was consulted in support of oracle, but at this time there is not solution and they want to open a new bug.
>
>The odbc-postgres part runs independiently but not in conjunction with dg4odbc. It seems in your system this communication is ok. (SQLGetInfo fails...)
>
>I have freedom in choose odbc and postgresql(I have the data only) versions, but not oracle. I'm not an expert in odbc, neither postgresql and I don't know the interactions between drivers if conflicts arisen.
>
>Wich is the ideal environment and versions for this objective?
>
>Thank you very much.
>
>Raúl
>____
>
Well, if the only unixODBC you have is 2.2.14, and you have this set in 
the dg4odbc files, then just edit the source of the postgres drivers and 
change all cases of WITH_UNIXODBC in the .c source to something not defined.

tar zxvf psqlodbc-08.03.0400.tar.gz
cd psqlodbc-08.03.0400
sed -i '/WITH_UNIXODBC/s//WITH_OLDUNIXODBC/' *.c
./configure --disable-unicode
make
make install

-- 
Nick
_______________________________________________
unixODBC-support mailing list
unixODBC-support at mailman.unixodbc.org
http://mailman.unixodbc.org/mailman/listinfo/unixodbc-support


More information about the unixODBC-support mailing list