[unixODBC-support] Conflicting types between postgres andunixodbc

Nick Gorham nick at lurcher.org
Fri Mar 27 09:30:42 GMT 2009


Raul Orduna wrote:

>I see that I have files of versions 2.2.14 (introduced by me) and files of version 2.2.11 (probably with the OS). How can I know the version used for odbc.ini... etc
>  
>
Well, the version of the lib libodbc.so is determined by your 
LD_LIBRARY_PATH, if you want to keep your system clean, then you could 
just build postgres against the development packages for your system 2.2.11

>How can clean my system?? And wich must I choose??
>  
>
Depends what you want. If the packages were installed by a package 
manager, uninstall the old one and keep the new. I can't tell you how to 
manage your system.

>Adding to that I do not control the options of prosgresql. If I used with_unixodbc wich files are replaced??
>  
>
I don;t understand this, sorry.

>Sorry, but I am desperate
>
Ok, go back a step, what is your goal?

-- 
Nick


More information about the unixODBC-support mailing list