[unixODBC-support] Can not get ODBC to log from other Database

Raul Orduna rorduna at tracasa.es
Wed Mar 25 12:36:59 GMT 2009


Do you have any change to obtain the logs??

>>
> Just tried it here, I got a log ok, the failure is:
>
> [ODBC][5190][SQLGetInfo.c][218]
>                Entry:
>                        Connection = 0x14750b0
>                        Info Type = SQL_CATALOG_NAME (10003)
>                        Info Value = 0x7fffa68768e0
>                        Buffer Length = 512
>                        StrLen = 0x7fffa6876b74
> [ODBC][5190][SQLGetInfo.c][537]
>                Exit:[SQL_ERROR]
>                DIAG [S1C00] Unrecognized key passed to SQLGetInfo.
>
> Thats using version 08.02.0500 of postgresql-odbc
>

The error is the same that I have.

>Just to add to that, I have just tried building psqlodbc-08.03.0400 of 
>the postgres driver and it seems to play nicely with dg4odbc

Sorry but, how do you make it?? I only use de postgres driver included in my distribution of unixODBC (2.2.14). How could I substitute it??


Raúl


More information about the unixODBC-support mailing list