[unixODBC-support] Invalid object name 'table'., SQL state S0002 in SQLExecDirect

Nick Gorham nick at lurcher.org
Mon Jun 29 15:51:49 BST 2009


Miguel A. Velasco wrote:
> Hi, thanks Gérard for your help but it doesn´t work for me. I´ve tried 
> what you commented and I have the following error message in Apache logs:
>
> [Mon Jun 29 16:20:10 2009] [error] [client 10.10.80.81] PHP Warning: 
> odbc_exec() [<a href='function.odbc-exec'>function.odbc-exec</a>]: SQL 
> error: [unixODBC][FreeTDS][SQL Server]Incorrect syntax near 
> 'MY_MICROSOFT_DOMAIN.OITM'., SQL state 37000 in SQLExecDirect in 
> /var/www/html/mydomain.com/index.php on line 7
> [Mon Jun 29 16:20:10 2009] [error] [client 10.10.80.81] PHP Warning: 
> odbc_fetch_row(): supplied argument is not a valid ODBC result 
> resource in /var/www/html/mydomain.com/index.php on line 9
>
> I´ve tried with my Active Directory Domain Name but it still doesn´t 
> work. I really don´t knwo where I can find a domain name in Sql Server 
> 2005, do you?
>
I think he means a user name. I would get the query working using isql 
first. If it doesn't work then in php you are not connecting to the same 
database.

-- 
Nick


More information about the unixODBC-support mailing list