[unixODBC-support] Solaris 10 - Sparc 64bits Sun Microsystem - make error

ithier.ctr at jdi.socom.mil ithier.ctr at jdi.socom.mil
Fri Jun 5 16:25:26 BST 2009


I am new on unixodbc, I am running Sybase 12.5 on SPARC 64bits with
Solaris 10 OS.
I am using perl(sparc) 5.8.5, libiconv(sparc) 1.8, gcc-3-3.4.6,
DBI-1.48, and DBD-Sybase-1.07.
I am able to access the Sybase databases, using Apache Web Page and Perl
language.  The Sybase Server and Apache Web are in the same
Unix/Solaris10 server.

My new goal is to access other database on a Microsoft SQL 2005 Server
from my Unix server.
To accomplish my new goal, first I tried to install the DBD-ODBC-1.11,
but I get the error message that I need a driver manager.  Then I
decided to install unixODBC-2.2.14 to get the driver manager.

To compile this package I executed 'sh ./configure --enable-gui=no' and
worked fine, but the 'make' command failed.  The last lines of the
console are as follow:

if /bin/bash ../libtool --tag=CC --mode=compile gcc -DPACKAGE_NAME=\"\"
-DHAVE_STRCHR=1 -DUNIXODBC_SOURCE=1  -I. -I. -I../include  -I../libltdl
-DSHLIBEXT=\".so\"  -DSYSTEM_FILE_PATH=\"/usr/local/etc\"
-DSYSTEM_LIB_PATH=\"/usr/local/lib\"  -DUNICODE_ENCODING=\"auto-search\"
-DUNIXODBC_SOURCE  -DASCII_ENCODING=\"auto-search\"     -g -O2
-DENABLE_INI_CACHING -MT __info.lo -MD -MP -MF ".deps/__info.Tpo" -c -o
__info.lo __info.c; \

then mv -f ".deps/__info.Tpo" ".deps/__info.Plo"; else rm -f
".deps/__info.Tpo"; exit 1; fi
-DUNIXODBC_SOURCE=1 -I. -I. -I../include -I../libltdl -DSHLIBEXT=\".so\"
-DSYSTEM_LIB_PATH=\"/usr/local/lib\" -DUNICODE_ENCODING=\"auto-search\"
-DENABLE_INI_CACHING -MT __info.lo -MD -MP -MF .deps/__info.Tpo -c
__info.c  -fPIC -DPIC -o .libs/__info.o
__info.c:480:6: invalid preprocessing directive #char
*** Error code 1
make: Fatal error: Command failed for target `__info.lo'
Current working directory
*** Error code 1
The following command caused the error:
failcom='exit 1'; \
for f in x $MAKEFLAGS; do \
  case $f in \
    *=* | --[!k]*);; \
    *k*) failcom='fail=yes';; \
  esac; \
done; \
dot_seen=no; \
target=`echo all-recursive | sed s/-recursive//`; \
list='extras  log  lst  ini  libltdl  odbcinst  DriverManager  odbcinstQ
odbcinstQ4  exe  cur  DRVConfig  Drivers  include  doc  ODBCConfig
DataManager  DataManagerII  odbctest  autotest  samples'; for subdir in
$list; do \
  echo "Making $target in $subdir"; \
  if test "$subdir" = "."; then \
    dot_seen=yes; \
    local_target="$target-am"; \
  else \
    local_target="$target"; \
  fi; \
  (cd $subdir && make  $local_target) \
  || eval $failcom; \
done; \
if test "$dot_seen" = "no"; then \
  make  "$target-am" || exit 1; \
fi; test -z "$fail"
make: Fatal error: Command failed for target `all-recursive'

Please Advise,


More information about the unixODBC-support mailing list