[unixODBC-support] unixODBC build problem on AIX

Brian Gadell bgadell at gmail.com
Thu Feb 26 15:32:37 GMT 2009


After successfully configuring with:
./configure --prefix=/ebiz --enable-gui=no --enable-drivers=no

I receive the following error during make:

make[1]: Entering directory `/ebiz/src/unixODBC-2.2.14/odbcinst'
if /bin/sh ../libtool --tag=CC --mode=compile gcc -DPACKAGE_NAME=\"\"
-DPACKAGE_TARNAME=\"\" -DPACKAGE_VERSION=\"\" -DPACKAGE_STRING=\"\"
-DPACKAGE_BUGREPORT=\"\" -DPACKAGE=\"unixODBC\" -DVERSION=\"2.2.14\"
-DYYTEXT_POINTER=1 -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1
-DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1
-DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_SYS_SEM_H=1
-DHAVE_DLFCN_H=1 -DHAVE_ICONV=1 -DICONV_CONST= -DHAVE_LIBCRYPT=1
-DTIME_WITH_SYS_TIME=1 -DHAVE_SYS_TIME_H=1 -DSIZEOF_LONG=4
-DHAVE_LONG_LONG=1 -DSIZEOF_LONG_INT=4 -DHAVE_STRCASECMP=1
-DHAVE_STRNCASECMP=1 -DHAVE_VSNPRINTF=1 -DHAVE_STRTOL=1 -DHAVE_ATOLL=1
-DHAVE_STRTOLL=1 -DHAVE_ENDPWENT=1 -DHAVE_GETTIMEOFDAY=1 -DHAVE_FTIME=1
-DHAVE_TIME=1 -DHAVE_LIBTHREAD=1 -D_REENTRANT=1 -DHAVE_LOCALTIME_R=1
-DHAVE_FTOK=1 -DHAVE_SEMGET=1 -DHAVE_SHMGET=1 -DHAVE_SEMOP=1
-DHAVE_SNPRINTF=1 -DNEED_SEMUNDO_UNION=1 -DCOLLECT_STATS=1 -DSTDC_HEADERS=1
-DHAVE_MALLOC_H=1 -DHAVE_UNISTD_H=1 -DHAVE_PWD_H=1 -DHAVE_CRYPT_H=1
-DHAVE_LIMITS_H=1 -DHAVE_SYNCH_H=1 -DHAVE_STRINGS_H=1 -DHAVE_STRING_H=1
-DHAVE_LOCALE_H=1 -DHAVE_SYS_MALLOC_H=1 -DHAVE_SYS_TYPES_H=1
-DHAVE_SYS_SEM_H=1 -DHAVE_STDARG_H=1 -DHAVE_SYS_TIME_H=1
-DHAVE_SYS_TIMEB_H=1 -DHAVE_TIME_H=1 -DHAVE_DIRENT_H=1 -DHAVE_ALLOCA_H=1
-DHAVE_ALLOCA=1 -DHAVE_VPRINTF=1 -DHAVE_DOPRNT=1 -DHAVE_PUTENV=1
-DHAVE_SOCKET=1 -DHAVE_STRDUP=1 -DHAVE_STRSTR=1 -DHAVE_SETENV=1
-DHAVE_SETLOCALE=1 -DHAVE_STRCHR=1 -DUNIXODBC_SOURCE=1 -I. -I. -I../include
-DSYSTEM_FILE_PATH=\"/ebiz/etc\" -DDEFLIB_PATH=\"/ebiz/lib\"
-DSHLIBEXT=\".so\" -DUNIXODBC_SOURCE -I../libltdl    -g -O2
-DENABLE_INI_CACHING -MT SQLGetPrivateProfileString.lo -MD -MP -MF
".deps/SQLGetPrivateProfileString.Tpo" -c -o SQLGetPrivateProfileString.lo
SQLGetPrivateProfileString.c; \
then mv -f ".deps/SQLGetPrivateProfileString.Tpo"
".deps/SQLGetPrivateProfileString.Plo"; else rm -f
".deps/SQLGetPrivateProfileString.Tpo"; exit 1; fi
 gcc -DPACKAGE_NAME=\"\" -DPACKAGE_TARNAME=\"\" -DPACKAGE_VERSION=\"\"
-DPACKAGE_STRING=\"\" -DPACKAGE_BUGREPORT=\"\" -DPACKAGE=\"unixODBC\"
-DVERSION=\"2.2.14\" -DYYTEXT_POINTER=1 -DSTDC_HEADERS=1
-DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1
-DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1
-DHAVE_UNISTD_H=1 -DHAVE_SYS_SEM_H=1 -DHAVE_DLFCN_H=1 -DHAVE_ICONV=1
-DICONV_CONST= -DHAVE_LIBCRYPT=1 -DTIME_WITH_SYS_TIME=1 -DHAVE_SYS_TIME_H=1
-DSIZEOF_LONG=4 -DHAVE_LONG_LONG=1 -DSIZEOF_LONG_INT=4 -DHAVE_STRCASECMP=1
-DHAVE_STRNCASECMP=1 -DHAVE_VSNPRINTF=1 -DHAVE_STRTOL=1 -DHAVE_ATOLL=1
-DHAVE_STRTOLL=1 -DHAVE_ENDPWENT=1 -DHAVE_GETTIMEOFDAY=1 -DHAVE_FTIME=1
-DHAVE_TIME=1 -DHAVE_LIBTHREAD=1 -D_REENTRANT=1 -DHAVE_LOCALTIME_R=1
-DHAVE_FTOK=1 -DHAVE_SEMGET=1 -DHAVE_SHMGET=1 -DHAVE_SEMOP=1
-DHAVE_SNPRINTF=1 -DNEED_SEMUNDO_UNION=1 -DCOLLECT_STATS=1 -DSTDC_HEADERS=1
-DHAVE_MALLOC_H=1 -DHAVE_UNISTD_H=1 -DHAVE_PWD_H=1 -DHAVE_CRYPT_H=1
-DHAVE_LIMITS_H=1 -DHAVE_SYNCH_H=1 -DHAVE_STRINGS_H=1 -DHAVE_STRING_H=1
-DHAVE_LOCALE_H=1 -DHAVE_SYS_MALLOC_H=1 -DHAVE_SYS_TYPES_H=1
-DHAVE_SYS_SEM_H=1 -DHAVE_STDARG_H=1 -DHAVE_SYS_TIME_H=1
-DHAVE_SYS_TIMEB_H=1 -DHAVE_TIME_H=1 -DHAVE_DIRENT_H=1 -DHAVE_ALLOCA_H=1
-DHAVE_ALLOCA=1 -DHAVE_VPRINTF=1 -DHAVE_DOPRNT=1 -DHAVE_PUTENV=1
-DHAVE_SOCKET=1 -DHAVE_STRDUP=1 -DHAVE_STRSTR=1 -DHAVE_SETENV=1
-DHAVE_SETLOCALE=1 -DHAVE_STRCHR=1 -DUNIXODBC_SOURCE=1 -I. -I. -I../include
-DSYSTEM_FILE_PATH=\"/ebiz/etc\" -DDEFLIB_PATH=\"/ebiz/lib\"
-DSHLIBEXT=\".so\" -DUNIXODBC_SOURCE -I../libltdl -g -O2
-DENABLE_INI_CACHING -MT SQLGetPrivateProfileString.lo -MD -MP -MF
.deps/SQLGetPrivateProfileString.Tpo -c SQLGetPrivateProfileString.c  -DPIC
-o .libs/SQLGetPrivateProfileString.o
SQLGetPrivateProfileString.c:66: error: syntax error before 'mutex_ini'
SQLGetPrivateProfileString.c:66: warning: data definition has no type or
storage class
SQLGetPrivateProfileString.c:68: error: syntax error before '*' token
SQLGetPrivateProfileString.c: In function 'mutex_entry':
SQLGetPrivateProfileString.c:70: error: 'mutex' undeclared (first use in
this function)
SQLGetPrivateProfileString.c:70: error: (Each undeclared identifier is
reported only once
SQLGetPrivateProfileString.c:70: error: for each function it appears in.)
SQLGetPrivateProfileString.c: At top level:
SQLGetPrivateProfileString.c:73: error: syntax error before '*' token
SQLGetPrivateProfileString.c: In function 'mutex_exit':
SQLGetPrivateProfileString.c:75: error: 'mutex' undeclared (first use in
this function)
make[1]: *** [SQLGetPrivateProfileString.lo] Error 1
make[1]: Leaving directory `/ebiz/src/unixODBC-2.2.14/odbcinst'
make: *** [all-recursive] Error 1

I can't seem to find help through any of my searches, so I'm asking for
help.  I'm on an AIX 5.3 host, but using gcc and mostly open source
libraries and utilities.  Any ideas?

-brian
bgadell at gmail.com

(Apologies if this comes through twice, I'm just not sure it got through the
first time...)
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.unixodbc.org/pipermail/unixodbc-support/attachments/20090226/e74e6678/attachment.html>


More information about the unixODBC-support mailing list