[unixODBC-support] unixODBC and Informix

Nick Gorham nick.gorham at easysoft.com
Mon Jul 21 09:12:26 BST 2008


Don_Arnett at ned.uscourts.gov wrote:

>Yes, I've followed up on that last year when I hit this problem.  IBM does
>not have a Linux version of that patch.
>
>I can get the Informix drivers to work fine with PHP w/PDO, but it's not a
>very portable solution and other courts would like to use my program.
>
>  
>
>>There is workaround exist, while linking(your application) if you use
>>libifgls.so library (i.e -lifgls) then you will not see this issue.
>>    
>>
>
>I don't remember that you provide source code for unixODBC.  Can it be
>compiled with libifgls?
>  
>
Should be simple enough to add it to the link line and relink libodbc.so 
or if your OS does it use a LD_PRELOAD

-- 
Nick Gorham
Easysoft Limited
http://www.easysoft.com, http://www.unixODBC.org




More information about the unixODBC-support mailing list