[unixODBC-support] ODBC on HPUX IA 64

Nick Gorham nick.gorham at easysoft.com
Thu Jul 3 14:47:27 BST 2008


Neha Avasthy wrote:

>Hi ,
>
>
>We have been using unixODBC-2.2.12 Driver  on several Unix platforms .
>However on HPUX IA64 the libraries get created as
>
> ls -l libodbc.so*
>lrwxrwxr-x  libodbc.so -> libodbc.so.1.0
>lrwxrwxr-x  libodbc.so.1 -> libodbc.so.1.0
>-rwxrwxr-x  libodbc.so.1.0
>where as on Linux/ Solaris they get created as
>
>
>ls -l libodbc.so*
>lrwxrwxrwx libodbc.so -> libodbc.so.1.0.0
>lrwxrwxrwx libodbc.so.1 -> libodbc.so.1.0.0
>-r-xr-xr-x     libodbc.so.1.0.0
>
>
>SO the minor version number seems to be missing on HPUX IA64 . Same
>observation is true for AIX as well.
>
>WHy is this difference in versioning  across paltforms?
>
>Thanks
>-Neha
>  
>
That will be down to the choices libtool is making for the platform I guess

-- 
Nick Gorham
Easysoft Limited
http://www.easysoft.com, http://www.unixODBC.org




More information about the unixODBC-support mailing list