[unixODBC-support] Forcing ISQL to use ODBC3 connection

Nick Gorham nick.gorham at easysoft.com
Tue Sep 11 09:40:21 BST 2007


Abhishek Srivastava wrote:

>Hi,
>I took the source code from this URL, and built it successfully. But when I
>try to build psqlodbc-08.02.0400, I get the following error:
>/export/home/unixODBC-2.2.13pre//include/sql.h:604: error: previous
>declaration of 'SQLColAttribute' was here
>odbcapi30.c:129: error: conflicting types for 'SQLColAttribute'
>/export/home/unixODBC-2.2.13pre//include/sql.h:604: error: previous
>declaration of 'SQLColAttribute' was here
>*** Error code 1
>make: Fatal error: Command failed for target `odbcapi30.lo'
>Current working directory /export/home/psqlDriversrc/psqlodbc-08.02.0400
>*** Error code 1
>
>Any pointers on that?
>
>  
>
2.2.13 has the same SQL_ULEN defs for SQLColAttribute that the current 
MS mdac headers have.

-- 
Nick Gorham
Easysoft Limited
http://www.easysoft.com, http://www.unixODBC.org




More information about the unixODBC-support mailing list