[unixODBC-support] RE: RE: Repost - Install questions

Martin Evans martin.evans at easysoft.com
Thu Jun 21 14:17:37 BST 2007


With respect Howard, you do not seem to be helping yourself sort your 
problems out or assist anyone else understand your problem so they can 
help you out.

So far we know from the many postings:

Your running Solaris 10 on Sparc
You are using a third party ODBC driver
This third party ODBC driver is 64bit
You get a bus error somewhere
You are following instructions on how to build unixODBC from this third 
party ODBC driver manufacturer, they are not working and coming back 
here to tell us you've found bugs in unixODBC.

I can assure you that unixODBC builds on Solaris 10, Sparc in 64bit mode 
and works with 64 ODBC drivers I've tested it with. However, there are 
multiple ways to build 64bit support and it is possible your problem 
lies here somewhere.

Why not take some time out, follow the instructions you have on building 
unixODBC the way your third party ODBC driver manufacturers suggest you 
should (from scratch) and when you hit your first issue you get stuck 
with post it here again with:

1. version of unixODBC you are building
2. configure line you used and any env vars you set
3. compiler you are using
4. a full description of the problem including what you did to see the 
problem and what you saw that makes you think there is a problem.
5. if you get as far as trying to connect to an ODBC driver let us know 
what driver that is, what version and where we can find it to try it 
ourselves.
6. if you get a core dump run a debugger on it so we can see the call stack.
7. if unixODBC is started, turn unixODBC logging on and include at least 
the last part of the trace.

Martin

Stein, Howard wrote:
>> Ok, thats fine, I just said how WE build it :-)
> 
> Yes, I'm not saying there way is right or wrong but I have to give it a
> try.  The other thing is, regardless of whether it's used or not, the
> LDFLAGS not getting added to the links is in my opinion a bug, I also
> noticed on the Sourceforge.net someone complained about a linux build
> and not having -lX11 or something like that not coming through on links.
> Sounded like the same problem to me.
> 
>>> 2) I was too tired last night to resolve the ld issue so just as a
> quick
>>> test I built the 32 bit with the sun compiler.  Interestingly, isql no
>>> longer gets the bus error and core dump but the other application I'm
>>> using is still getting the core dump.  If the sql statement is the
> same
>>> (select * from owner.table), and both are using the same oracle odbc
>>> library, any thoughts on why one would work and not the other?  I'm
> just
>>> looking for insights and theoretical to get me thinking a bit.
>>>
> 
> I had a thought and I asked it of kx, I think their software may be
> using a hard coded location for the driver manager as opposed to the
> path so if that's the case then I suspect it's still calling the gcc
> version installed under root (a big process to do here) and not the test
> version that worked with isql.  This would be great, my problems would
> be solved and this issue put to bed (other than getting a clean 64 bit
> build since Oracle recommends that over the 32 bit).
> _______________________________________________




More information about the unixODBC-support mailing list