[unixODBC-support] Data source name not found and no default driver specified

Nick Gorham nick.gorham at easysoft.com
Mon Oct 16 09:35:46 BST 2006


Sven Jacobs wrote:

> Dear mailing list,
>
> I'm trying to connect to a MaxDB database using unixODBC (version 2.2.8)
> on SuSE Linux 9.1. I've created the necessary entries in
> /etc/unixODBC/odbc.ini and /etc/unixODBC/odbcinst.ini by using 
> ODBCConfig:
>
> --snip----odbc.ini----snip--
> [TEST]
> Description = SAPDB
> Driver = SAPDB
> ServerNode = 192.168.100.150
> ServerDB = TEST
> --snip----------------snip--
>
> --snip--odbcinst.ini--snip--
> [SAPDB]
> Description =
> Driver = /opt/sapdb/interfaces/odbc/lib/libsqlod.so
> Setup = /usr/lib/unixODBC/libsapdbS.so.1
> FileUsage = 1
> CPTimeout =
> CPReuse =
> --snip----------------snip--
>
> When I run "isql TEST -v" I get the error message:
>
> [IM002][unixODBC][SAP AG][LIBSQLOD SO]Data source name not found and no
> default driver specified.
> [ISQL]ERROR: Could not SQLConnect
>
> In DataManager the System DSN is shown but when I try to open it, after
> entering username and password, I get the same error message.
>
> Thanks for any help!
>
Looks like the driver is failing to find the ini entries. Maybe its not 
using libodbcinst.so, try setting ODBCINI=/etc/unixODBC/odbc.ini and see 
if that helps, other than that is there any help from the driver writers?

-- 
Nick Gorham
Easysoft Limited
http://www.easysoft.com, http://www.unixODBC.org




More information about the unixODBC-support mailing list