[unixODBC-support] odbcinst probelm

Nick Gorham nick.gorham at easysoft.com
Fri Jun 30 10:48:34 BST 2006


Nagesh Sharvari-A21337 wrote:

>Yeah.. I do know that it can be edited manually. But how does the new
>edited configuration, gets loaded? Should I restart the server or should
>I wait for certain time for it to get loaded or should I execute some
>command to tell odbc to use the modified configuration files?. Because,
>after manually, changing /etc/odbc.ini file, the changes are not getting
>loaded. 
>  
>
Its up to your app, is your app runs as a daemon its needs to stop and 
start (if the DM is built with ini caching), if its just a normal app, 
then it will be read the next time the app is run. unixODBC is not a 
service, its just a lib that is used in the app.

>I don't get any error message after executing a odbcinst command. It
>says, odbc.ini file is modified properly. But if I do a cat of
>/etc/odbc.ini file, it wouldn't have changed at all. May be it's trying
>to change some other .odbc.ini file. But I checked all .odbc.ini files,
>even they are not modified.
>  
>

Try using strace to check what its editing, and check you have write 
permission on the file.

>I am running odbcinst command using a user which has all root
>privileges. And I am also giving the option "-l" to indicate, it needs
>to change system odbc.ini file. Though, odbcinst says, 
>
>bash-2.03# odbcinst -u -s -l -n ORACLE
>odbcinst: DSN removed (if it existed at all). ODBC_BOTH_DSN was used as
>the search path.
>
>But if I do a cat of /etc/odbc.ini(and also other .odbc.ini files),
>ORACLE data source configuration wouldn't have changed at all. I even
>tried setting ODBC_BOTH_DSN variable to /etc, even that doesn't work. I
>even tried running this as root user. That also doesn't work.
>
>  
>
I will check this and see if there is a probelm with the removal.

-- 
Nick Gorham
Easysoft Limited
http://www.easysoft.com, http://www.unixODBC.org




More information about the unixODBC-support mailing list