[unixODBC-support] postgresql driver install problems

Nick Gorham nick.gorham at easysoft.com
Wed Jun 14 09:48:22 BST 2006


ricardd at mathstat.dal.ca wrote:

>Hello,
>I'm running postgresql 8.1.4 on Ubuntu 6.06 and installed the current
>unixodbc package (2.2.11).
>
>I can't figure out how to add a postgresql odbc driver in ODBCConfig.
>
>I originally downloaded and built the postgresql odbc driver from
>pgfoundry but the installed libraries do not have a "setup file"
>(libnameS.so). After I try to add the driver in ODBCConfig and set up a
>DNS, I get an error that it "Could not construct a property list for
>(drivername)".
>
>A previous posting on the psqlodbc mailing list suggests that I should use
>the unixodbc postgresql driver instead. However, I can't seem to locate
>the postgresql driver that I can feed to ODBCConfig.
>
>Any hints?
>Cheers,
>
>Daniel Ricard
>  
>
If you have the PG setup, it will be called libodbcpsqlS.so, you can 
always build the package from source to get the lib.

-- 
Nick Gorham
Easysoft Limited
http://www.easysoft.com, http://www.unixODBC.org




More information about the unixODBC-support mailing list