[unixODBC-support] Multiple data-sources not working

Nick Gorham nick.gorham at easysoft.com
Tue Dec 12 07:56:57 GMT 2006


Chris Ralph wrote:

>Hi,
>
>I installed unixODBC along with mdbtools to connect to ms access databases
>via odbc.  The problem is that regardless how many data sources I add in
>odbc.ini, it always uses the first database in the list..
>
>odbcinst.ini:
>----------------------
>[MDBToolsODBC]
>Description             = MDB Tools ODBC drivers
>Driver          = /usr/local/lib/libmdbodbc.0
>----------------------
>
>
>odbc.ini:
>----------------------
>[FTP]
>Description             = FTP list
>Driver          = MDBToolsODBC
>Database                = /home/skeleton-man/public_html/water/ftp.mdb
>Servername              = localhost
>UserName                =
>Password                =
>
>[Water]
>Description             = Water Module
>Driver          = MDBToolsODBC
>Trace           = Yes
>TraceFile               = /var/log/sql.log
>Database                = /home/skeleton-man/public_html/water/water.mdb
>Servername              = localhost
>UserName                =
>Password                =
>-----------------
>
>In the above example you can clearly see I'm referencing two different
>databases, but regardless what I change, the second datasource (Water)
>always connects to ftp.mdb instead of water.mdb.  If I were to swap the
>order of the data sources and put Water at the top, then both data sources
>would point to water.mdb and ftp.mdb would be ignored.
>
>I am running the latest version of unixODBC and at first thought this
>might've been a php bug, but the "isql" tool produces exactly the same
>results.
>
>Any ideas ?
>
>  
>
I would guess its a driver issue (can't be certain), its the driver that 
reads that entry. I don't know if it uses unixODBC help to do that, or 
does it directly.

-- 
Nick



More information about the unixODBC-support mailing list