[unixODBC-support] qt-odbc-mssql problem

Veliczky Rudolf veliczky.rudolf at axelero.hu
Sun May 1 08:28:35 BST 2005


Nick Gorham wrote:

> Veliczky Rudolf wrote:
>
>>
>> qGetStringData: Error while fetching data (-1) and
>> QODBCDriver::record: Unable to execute column list Error:
>> messages appears on console.
>>
>>
>> And yes,  no tables can be seen from database. The result is the same 
>> if i try to hand-code the necessary calls. Connection seems OK, but 
>> no records can be retrieved.
>>
>> What's wrong?
>>
>>
>> Thanks
>> Rudolf
>>
>>
> Not sure, but when I looked at QT's ODBC interface a year or so ago, 
> it seemed to require cursor support. Maybe a ODBC trace will show 
> whats failing, but I think the most likly problem is the driver.
>
> You could try with another driver to compair....
>
Hi Nick,

thanks for your reply.

The fact is that i've already tried a lot of different combinations with 
qt-unixodbc-freetds triangle. The "best" result comes from the formerly 
mentioned combination: no data, but no SEGFAULT neither. Beforehand, 
with other version combinations qt-designer or hand-coded app. 
"SEGFAULT-ed" as soon as tried to fetch data.

I'm afraid the blaim lies with qt's qodbc plugin, because tsql, isql, 
Datamanager can retrieve data form mssql, or even a simple php script 
that uses the test odbc dsn.

Afaik DatamanagerII was written in qt, and works... how?


Rudolf



More information about the unixODBC-support mailing list