[unixODBC-support] unixODBC+MDBTOOLS+ACCESS : Problem with WHERE conditions

Olivier BONHOMME olivier.bonhomme at b2i-toulouse.com
Fri Jan 21 14:52:54 GMT 2005


Eric Sharkey wrote:

>It looks odd. Why do you have a "]" between the table name and the
>column name?
>  
>
Hi Eric and thank you for your quick answer

Sorry, I had a "cut and paste problem". Actually, I have tried all the 
possibilites for building my query like using the "Access way" to 
describe the tables in the query which is [Table].[Column]. But with "[ 
]" or not, the problem is still the same.

While my investigation, I saw an error on http-errors.log (where php 
errors are logged) which says that there is a parsing error just after 
the where as if the WHERE keyword would be a mistake :

Error at Line : parse error near ListePropositions.REVISION
[Fri Dec 31 15:08:14 2004] [error] PHP Warning:  odbc_exec(): SQL error: 
[unixODBC]Couldn't parse SQL\n, SQL state 08001 in SQLExecDirect in 
/usr/home/ptitoliv/publi
c_html/testodbc.php on line 8

What do you think about it ?

Best Regards,

Olivier BONHOMME




More information about the unixODBC-support mailing list