[unixODBC-support] Informix problem

Nagy Gabor linux42 at freemail.hu
Thu Feb 24 11:28:56 GMT 2005


Hi!

I have seen on the unixodbc webpage that Informix access should be OK.

I have downloaded and installed the Informix Connect software, and I have
also installed the unixodbc package in my Linux distribution.

I have tried to configure unixodbc and the informix driver, but the
documentation I could find was not really sufficient.

I started with the manual on the unixodbc page. That was very light, then
there is a german document, which gave some more details.

Later with google I have found some spanish documentation, which has
contained even more information.

Now I have the following: I have a Linux box, with some configuration
files that are possibly not correct.

I also have a windows box where the same thing works.

So right now when I do an isql -v database, I got an error:
informix at swordfish:~$ isql -v cdw
[ISQL]ERROR: Could not SQLConnect

I have checked the archives of this list, and have seen a similar error
message.
I have checked my strace, found out that I did not have an informix.rc,
googled for it, what it was supposed to contain, then tried again, with
the same results.

I suppose it is a problem with the Informix ODBC driver setup, but I am
not sure.

And I would need the help of someone who has successfully managed to
connect to Informix from some unix like system.

Also I would gladly read some documentation that tells me how to configure
(and test) the ODBC driver itself, at first without unixodbc.

My guess is that the problem now lies with the driver configuration, not
with the unixodbc part.

Cheers,
Gabor



More information about the unixODBC-support mailing list