[unixODBC-support] cursor not supported in unixodbc?

Tom Lee tom_lee01 at hotmail.com
Wed Oct 27 08:59:48 BST 2004



>From: Nick Gorham <nick.gorham at easysoft.com>
>Reply-To: Support for the unixODBC project <unixodbc-support at easysoft.com>
>To: Support for the unixODBC project <unixodbc-support at easysoft.com>
>Subject: Re: [unixODBC-support] cursor not supported in unixodbc?
>Date: Wed, 27 Oct 2004 07:59:38 +0100
>
>Tom Lee wrote:
>
>>Hello,
>>
>>I tried unixODBC-2.2.5-9 and  MyODBC-3.51.09-1, and noticed that the SQL 
>>connect will fail
>>if  SQLSetConnectAttr (hdbc, SQL_ATTR_ODBC_CURSORS, (void 
>>*)SQL_CUR_USE_ODBC,0)
>>is used.
>>
>>The same code works fine with iodbc. Seems that unixodbc doesn't support 
>>cursors?
>>can somebody clarify for me?
>>Thanks.
>
>
>Hi,
>
>It should do, there is a cursor lib. Though 2.2.5 is some months old. try 
>the current 2.2.10 and let me know how it goes.
>
>From the version number, I guess you have installed from RPM, maybe the 
>makers of theRPM, didn't kno wto include the cursor library lib...

Yes. It is from Fedora version 1.
I tried myodbc 2.5 from Fedora, and then tried  MyODBC-3.51.09-1 RPM, it 
still not work.

I will try 2.2.10.


>
>What error do you get when the connect fails ?

Sorry, I really cannot recall now. It just failed at SQL Connect.
After commenting out,
SQLSetConnectAttr (hdbc, SQL_ATTR_ODBC_CURSORS, (void *)SQL_CUR_USE_ODBC,0),
the SQL Connect will success.

-T

>--
>Nick
>_______________________________________________
>unixODBC-support mailing list
>unixODBC-support at easysoft.com
>http://mail.easysoft.com/mailman/listinfo/unixodbc-support

_________________________________________________________________
Express yourself instantly with MSN Messenger! Download today - it's FREE! 
http://messenger.msn.click-url.com/go/onm00200471ave/direct/01/




More information about the unixODBC-support mailing list