[unixODBC-support] Segmentation fault when using isql

mysql_04 at yahoo.com mysql_04 at yahoo.com
Thu Aug 26 19:22:39 BST 2004


Nick Gorham wrote:

> mysql_04 at yahoo.com wrote:
>
>>
>> So version 2.2.2 produces a segmantation fault, and 2.2.9 doesn't 
>> have a library needed by MyODBC.
>>
>> Any suggestions on how to proceed from here would be appreciated.
>
>
> It will have libodbcinst.so, its just that as you haven't installed 
> from RPM, the system doesn't know its got it.
>
> Try forcing the install. You can check to be certain that there is a 
> libodbcinst.so.1 from the build.
>
Right again... Forcing the install using < rpm -ivh --nodeps > worked 
for the install.

I have modified the /etc/odbc.ini and etc/obdcinst,ini files and also 
copied them to /usr/local/etc

==========================
odbc.ini:

[MySQL-test]
Description = MySQL database test
Driver = MySQL
Server = localhost
Database = test
Port = 3306
Socket =
Option =
Stmt =

============================
odbcinst.ini:

# Example driver definitinions
#
#

# Included in the unixODBC package
[PostgreSQL]
Description = ODBC for PostgreSQL
Driver = /usr/lib/libodbcpsql.so
Setup = /usr/lib/libodbcpsqlS.so
FileUsage = 1


# From the MyODBC package
[MySQL]
Description = ODBC for MySQL
Driver = /usr/lib/libmyodbc.so
Setup = /usr/lib/libodbcmyS.so
FileUsage = 1

===============================

Running isql still fails:

[root at localhost MySQL_Connector_ODBC]# isql MySQL-test
[ISQL]ERROR: Could not SQLConnect
[root at localhost MySQL_Connector_ODBC]#

Same results with < isql MYSQL-test >

MySQL does work on its own.

Some other complications as well...
The < make install > of unixODBC dumped all the installed files (such as 
the doc directories) below my /root/temp directory. From the 
installations instructions it appeared that the <make install > would 
put these in their proper places. Obviously, that didn't happen. Can I 
just move the doc directory & files to /use/shared/doc? Can I simply 
move the /unixODBC-2.2.9/ directory to /usr/local/, perhaps? Or do I 
need to redo the <make install> routine again (from /usr/local/)? I 
don't want a bunch of required files sitting under a temp directory 
that's just used for mucking about.

...but it still doesn't work... There has to be something just dirt 
simple here that I'm not getting right. Do I need to run odbc_config or 
odbcinst before isql?

Dan





More information about the unixODBC-support mailing list