[unixODBC-support] cannot open shared object file libodbccr.1

David Kramer dave at fabco.com
Tue Aug 17 22:33:47 BST 2004


Just coming to Linux from the OpenVMS world, so somewhat guessing at
syntax...., would this be:

[root at xanth bin]# ln -s /usr/lib/libodbccr.so libodbccr.1

which created /usr/lib/libodbccr.1 -> /usr/lib/libodbccr.so

This returned the same error.....

-----Original Message-----
From: unixodbc-support-bounces at mail.easysoft.com
[mailto:unixodbc-support-bounces at mail.easysoft.com]On Behalf Of Paul
Mahon
Sent: Tuesday, August 17, 2004 4:25 PM
To: unixodbc-support at mail.easysoft.com
Subject: Re: [unixODBC-support] cannot open shared object file
libodbccr.1


Have you tried making a symlink from /usr/lib/libodbccr.1
to /usr/lib/libodbccr.so ?

On Tue, 2004-17-08 at 15:13 -0500, David Kramer wrote:
> More than slightly baffled, trying to connect to a MS SQL server database
> utilizing ADOdb.  I'm getting an error trying to connect of the following:
>
> [unixODBC][Driver Manager]Can't open cursor lib 'libodbccr' :
> /usr/lib/libodbccr.1 cannot open shared object file:  No such file
>
> I've verified that indeed, there is no libodbccr.1 in the /usr/lib
> directory, only:
> libodbccr.a libodbccr.so libodbccr.so.1 libodbccr.so.1.0.0
>
> I'm trying to utilize the freetds odbc driver which I've setup in
> ODBCCOnfig, and have tested with isql (isql -v MSSQLServer username
> password) and it works correctly.
>
> PHP is compiled thusly:
>
> './configure' '--host=i386-redhat-linux' '--build=i386-redhat-linux'
> '--target=i386-redhat-linux-gnu' '--program-prefix=' '--prefix=/usr'
> '--exec-prefix=/usr' '--bindir=/usr/bin' '--sbindir=/usr/sbin'
> '--sysconfdir=/etc' '--datadir=/usr/share' '--includedir=/usr/include'
> '--libdir=/usr/lib' '--libexecdir=/usr/libexec' '--localstatedir=/var'
> '--sharedstatedir=/usr/com' '--mandir=/usr/share/man'
> '--infodir=/usr/share/info' '--cache-file=../config.cache'
> '--with-config-file-path=/etc' '--with-config-file-scan-dir=/etc/php.d'
> '--enable-force-cgi-redirect' '--disable-debug' '--enable-pic'
> '--disable-rpath' '--enable-inline-optimization' '--with-bz2'
> '--with-db4=/usr' '--with-curl' '--with-exec-dir=/usr/bin'
> '--with-freetype-dir=/usr' '--with-png-dir=/usr' '--with-gd'
> '--enable-gd-native-ttf' '--without-gdbm' '--with-gettext'
'--with-ncurses'
> '--with-gmp' '--with-iconv' '--with-jpeg-dir=/usr' '--with-openssl'
> '--with-png' '--with-pspell' '--with-regex=system' '--with-xml'
> '--with-expat-dir=/usr' '--with-dom=shared,/usr' '--with-dom-xslt=/usr'
> '--with-dom-exslt=/usr' '--with-xmlrpc=shared' '--with-pcre-regex=/usr'
> '--with-zlib' '--with-layout=GNU' '--enable-bcmath' '--enable-exif'
> '--enable-ftp' '--enable-magic-quotes' '--enable-safe-mode'
> '--enable-sockets' '--enable-sysvsem' '--enable-sysvshm'
> '--enable-track-vars' '--enable-trans-sid' '--enable-yp' '--enable-wddx'
> '--with-pear=/usr/share/pear' '--with-imap=shared' '--with-imap-ssl'
> '--with-kerberos' '--with-ldap=shared' '--with-mysql=shared,/usr'
> '--with-pgsql=shared' '--with-snmp=shared,/usr' '--with-snmp=shared'
> '--enable-ucd-snmp-hack' '--with-unixODBC=shared,/usr'
> '--enable-memory-limit' '--enable-bcmath' '--enable-shmop'
> '--enable-calendar' '--enable-dbx' '--enable-dio' '--enable-mcal'
> '--enable-mbstring=shared' '--enable-mbstr-enc-trans' '--enable-mbregex'
> '--with-apxs2=/usr/sbin/apxs'
>
> Anyone have thoughts on how to get by this?
>
> Thanks in advance for your help
>
> -David
>
> _______________________________________________
> unixODBC-support mailing list
> unixODBC-support at mail.easysoft.com
> http://mail.easysoft.com/mailman/listinfo/unixodbc-support
>




More information about the unixODBC-support mailing list