[unixODBC-dev] 2.2.11 doesn't build on Fedora Core 3

Eric Sharkey sharkey at netrics.com
Fri Apr 8 05:13:04 BST 2005


> Hi folks,
>   I tried to update Red Hat's unixODBC distribution to 2.2.11, and found
> that it fails to build.  It looks like the recent addition of an
> export-symbols list to libodbcinst is preventing DataManager from
> getting at the "ini" library routines.  How come no one but me is seeing
> this?

If you read the list archives, you'll see that that's not the case.
Peter, Nick, and I have all posted on this topic.

> Any thoughts on the cleanest fix?

If you build with libtool 1.4 it should build.

Ultimately, some reorganization of libraries is needed.  If you want it
to "just work" with minimal effort, you can also remove the export-symbols
list and compile it that way.  That will restore the 2.2.10 behavior.

Peter has checked in patches to several of the Makefile.am's to
explicitly link to the ini, lst, and log libraries when necessary,
but that code isn't available in a tagged release.

Eric



More information about the unixODBC-dev mailing list